Jump to content
WernHalen

ASIO setup/drivers for Creative Audigy 2 NX

Recommended Posts

Hi,

I have been struggling the whole weekend to be able to record a song. I am using a Creative Soundblaster Audigy 2 NX. Great sound card, but if you lost the installation CD you are in trouble. Creative does not support the machine if you dint have the original drivers on the machine. You cant download the drivers you have to buy another CD. :mad: I spent a pretty penny on the sound card the leat they could do is put up some sort of solution for us noobs out there that lose cd's. i have tried installing the KX project drivers as well as ASIO4ALL but nothing seems to work. :brickwall: :brickwall: :brickwall: I found a couple of ways to install drivers for the card, by tricking it... sneaky sneaky... but it does not want to work...

Has anybody out there have a solution for me? I am at my wits end. :helpsmili

As far as I know the ASIO4ALL drivers seem to work just fine but it has a problem with the WDM driver... If anybody knows of a place where i can find such a driver or replacement driver please let me know...

As a matter of principle i dont want to get another CD from creative. I will give it a couple of days and if I cant find a solution on the web i'll buy the CD again... I'll probably have to import it. :mad: :mad: :mad:

Share this post


Link to post
Share on other sites

Hey Wern, You don't need asio4all with the Audigy card as it has it's own Creative ASIO

bundled with the installation drivers...!!!

Here is the link: Audigy 2 NX Drivers

The WDM format, as well as Direct X are alternatives to ASIO, and will not deliver the same

quality...!!!

Cheers

Ben

Share this post


Link to post
Share on other sites

Ben,

Thanks, I will definitely try the drivers... I have been trying to download the ISO from emule over the weekend, but that is 600Mb and over a dial up that will take forever... I usually smirk at the mention of emule but I have no problem downloading this ISO since I already own it, i just misplaced it.

According to the guys at the ASIO4all forum the creative drivers suck and when they installed the asio4all. I tried it but could not get it to work at all...

Thanks again... I'll let you know what I find.

Share this post


Link to post
Share on other sites

Be careful Wern... 3rd party drivers usually will not work well with creative stuff...

The link I gave you is for genuine creative drivers...

I tried asio4all on a Audigy card with very little success also...!!!

There is no way an ASIO driver can be 600 mb... At the most it should be 10 or 11 mb...!!!

Let me know if I can help further...!!!

Cheers

Ben

Share this post


Link to post
Share on other sites

Kush,

Thanks for the reply. My son is doing absolutely wonderfull. I am guessing that he was a bit sad during the weekend seeing that I spent a lot of time trying to get the PC to record properly... I did spend alot of time with him during downloads though... :)

I didn't even pick up my guitar once except to try to record when I thought everything was fine... :brickwall:

Thanks for the link Kush, unfortunately this is one of the sites where I found most of the drivers that did not want to work. You are required to have all their software installed otherwise you wont be able to install any new drivers. Unfortunately I lost the CD a during a move and I lost the Harddrive a while back. So I dont have any of the pieces of software required to install the drivers... :(

I found a site where someone found a way to install the drivers in a funny way to trick the pc into installing them. This did not work well either cause, I installed the driver and whe I wanted to run the thing it told me the software was not installed... :huh::no::mad:

Ahh well... Note to myself never buy a creative machine ever again... :no:

Share this post


Link to post
Share on other sites
Kush,

Thanks for the reply. My son is doing absolutely wonderfull. I am guessing that he was a bit sad during the weekend seeing that I spent a lot of time trying to get the PC to record properly... I did spend alot of time with him during downloads though... :)

I didn't even pick up my guitar once except to try to record when I thought everything was fine... :brickwall:

Thanks for the link Kush, unfortunately this is one of the sites where I found most of the drivers that did not want to work. You are required to have all their software installed otherwise you wont be able to install any new drivers. Unfortunately I lost the CD a during a move and I lost the Harddrive a while back. So I dont have any of the pieces of software required to install the drivers... :(

I found a site where someone found a way to install the drivers in a funny way to trick the pc into installing them. This did not work well either cause, I installed the driver and whe I wanted to run the thing it told me the software was not installed... :huh::no::mad:

Ahh well... Note to myself never buy a creative machine ever again... :no:

Hi Buddy

I'm trying to download the Software package to my PC, and it is downloading. Its about 21 Mb and after the same has been completed, I'll try to upload it onto a Website and give you the link.

I'll be back within an hour or so. Dont worry Pal, we will sort it out :yes:

Kindest Regards

Kush

Share this post


Link to post
Share on other sites

Hi Buddy !!

I'm so sorry, I forgot to ask "Which Operating Syste do you use ???" I've downloaded it for Window XP, but no problems if you use any other just tell me now, and I'll re-download it now. Please reply :)

Thanks and Regards

Kush

Share this post


Link to post
Share on other sites

Thanks Kush,

I actually think i already downloaded the driver you are talking about... It is a 21.6Mb application. i downloaded both AUDX_WEBUP_LA_1_00_0010 and SBA2_WEB64_LB_2_03_0003 unfortunately it says that i dont have the soundcards' software installed on my pc when I run it...

Unfortunately I can only test the drivers Ben has supplied tonight. I'll let you know the day after tomorrow as I am not at the office tomorrow.

Share this post


Link to post
Share on other sites

Ben, almost missed you post... jip i know an ASIO driver cant be 600MB but it is not the driver i wanted to download it was the complete installation CD (ISO not ASIO... :) ) An ASIO driver should not be more than a couple of MB you are right.

like i said to Kush, I have downloaded the drivers you suggested and i will try them as soon as I get home...

Thanks Pal.

Share this post


Link to post
Share on other sites

Ben, Kush,

I've tried and was sucsessfull in installing the drivers, Bbuuuttt...

As soon as I want to use the ASIO there is a Creative window that POPS up and tells me that the soundcards software is not installed and that it will exit... :mad: I also had to trick the drivers into installing as the installation program for the drivers did not want to complete the installation because the software for the card is not installed... :mad:

Creative is really making me mad and I will never buy another creative product if this is the way they want to do business. :thumbdown:censored:

Anybody have clues about where i should go next??? :helpsmili

Share this post


Link to post
Share on other sites
hmm, Wernhalen, by any chance, is your sound card an external one that connects through USB?

Clancy

Hi Buddy

May be what Clancy says is right. Checked it ? Do you connect your Sound Card via USB (I mean is it an external one ?)

Regards

Kush

Share this post


Link to post
Share on other sites

Creative is really making me mad and I will never buy another creative product if this is the way they want to do business. :thumbdown:censored:

Anybody have clues about where i should go next??? :helpsmili

Hi Pal

Did you try contacting the Computer-Store from where you bought the System or the Sound Card ? May be their technician can help ? Just consider this as an option, I'm thinking about other possibilities and I'll tell you here, if something strikes....

Dont worry Pal, We will sort it out together :yes:

Kindest Regards and lots of Care

Kush

Share this post


Link to post
Share on other sites
As soon as I want to use the ASIO there is a Creative window that POPS up and tells me that the soundcards software is not installed and that it will exit... :mad: I also had to trick the drivers into installing as the installation program for the drivers did not want to complete the installation because the software for the card is not installed... :mad:

May I also know, How're you trying to use ASIO ? I mean which software are you trying to use for recording, that uses ASIO ?

Kindly reply, so that I can further study for you.

Kindest Regards

Kush

Share this post


Link to post
Share on other sites

Clancy,

Yes it is an external USB device... would this help in getting a fix?

Kush,

I have tried getting support from them, but they dont stock these things. Mine was a special order which someone did not pick up... I will see if i can find a store which stocks it and then by it on appro if they wont let me borrow or copy the cd. I'll just return the CD and card after I copied the CD...

I wont like doing something like that, it just feels wrong. That is why i am trying to get it off the net first.

Thanks for the support guys...

Share this post


Link to post
Share on other sites
Clancy,

Yes it is an external USB device... would this help in getting a fix?

I think I may have those disks. Kirk has that sound card. We bought it, but never got around to using it.

I'll have a look for you if you like.

Clancy

Share this post


Link to post
Share on other sites

Kush,

I have tried getting support from them, but they dont stock these things. Mine was a special order which someone did not pick up... I will see if i can find a store which stocks it and then by it on appro if they wont let me borrow or copy the cd. I'll just return the CD and card after I copied the CD...

I wont like doing something like that, it just feels wrong. That is why i am trying to get it off the net first.

Thanks for the support guys...

Hi Buddy

I dont think that is wrong. You've paid them for your Sound-Card and Lost the Driver-Cd. Now, there's really nothing wrong in borrowing the Driver cd and making a Copy for your future use. This is not wrong atall !!! Sorry If I'm wrong, but this is my personal opinion.

Anyways I really wish, it will work out for you :)

Kindest Regards

Kush

Share this post


Link to post
Share on other sites

I wanted to suggest one more thing. Please check your USB Port Pal. This happened to me recently, when my USB printer suddenly stopped functioning. The System showed no printer attached. After I plugged it into the other USb Port, it worked !!!

The Problem was not with the Printer and it was the USB Port that had been mal-functioning. I feel this may be the case there too ! If the USB Port is'nt functioning, there will be no Sound Card detected !!! Plugging it into the other USB Port may solve it.

Please Try this and reply, Buddy

-Kush

Share this post


Link to post
Share on other sites

Kush,

I am trying to use Cubase SX, it is a expensive program in these parts and i would hate to have it go to waste because I cant use the sound card... I have tried recording with Audacity as well but the same problems i am having in Cubase is copied there... :(

Clancy,

You would be such a darling if you do have the CD... I would be willing to pay for copying the CD and mailing it here... :)

Something i dont understand though is this. How do you buy an expensive sound card and not use it? I have read the same comments on a couple of home recording forums as well, where a person buys a card and only wants to use it three years down the line... :confused: Maybe its just me but I only buy something if and when I can use it... :yes:

Oh and I am certainly not trying to critisize... :no: I am just too glad to find some help...

Share this post


Link to post
Share on other sites

May be you can try this :

Remove the Card from the USB port and try connecting some other USB device into the same USB port (like a USB Mouse, or a USB Card Reader etc) and see if it works in this USB Port. If it does, then we can be sure that there's nothing wrong with the USB Port. I think we can eliminate our doubts this way and come to a concrete solution. Maybe this helps :unsure:

Kindly try this and let me know, I'm studying and analysing this further and will let you know if I comeacross anything else.

Kindest Regards

Kush

P.S : How's the little one doing, Pal !!! I hope great !!!! Kindly give my regards and love to him :)

Share this post


Link to post
Share on other sites

It is not really in the borrowing the CD but the way in which I would have to go about it to get the CD... I dont really have a concience as i have been relieved of that a couple of years back, it is just that I would not like doing that.

Lets say I get the card from a shop. i buy the card and copy the cd, then take it back. The shop possibly could have lost a legit sale on the card during the time i had the card with me. Also i think the card would loose some sales value if the box has been opened... This way the shop might loose due to something someone else did...

Share this post


Link to post
Share on other sites

The little one is doing very well Kush. We are having a nasty winter. Nasty in the sense that it started early this year by about two months and it is very cold for South Africa. He had a little bit of a hoarse throat over the weekend but that's all over now. I played with him last night and he just made my day... :D My wife is feeling abit under the weather though... Flu...

Share this post


Link to post
Share on other sites

Something i dont understand though is this. How do you buy an expensive sound card and not use it? I have read the same comments on a couple of home recording forums as well, where a person buys a card and only wants to use it three years down the line... :confused: Maybe its just me but I only buy something if and when I can use it... :yes:

To tell you the truth, I bought it in the middle of one of my eBay buying frenzies... we installed it and couldn't get it working with Audition. I can't remember the problem but at the time Kirk was right in the middle of some project and didn't really want to spend a lot of time trying to get it working. It seemed to slow his computer down quite a bit too, so we uninstalled it.

Kirk has since bought a new computer and the built in sound card seems ok, so we haven't really thought much about trying to install it all again. I hadn't even really thought about it at all until I read this thread and the name clicked.

Anyway, I'll look for the installation CD's for you and let you know.

Clancy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×