Jump to content
hb

Re: Old "ASIO4ALL" post

Recommended Posts

I am having a latency issue with Audacity and a search on Google brought up an old link on this site suggesting the download of a driver called "ASIO4ALL". I got the download but am unable to do anything with it and was wondering if someone familiar with this might help. ??

hb

Share this post


Link to post
Share on other sites

I'm not sure if it will work or not. It's my understanding that Audacity is a wave editor and not a multi-sequencer like other programs like Reaper, Sonar, etc. I use Sonar and I know many people use ASIO for all as a WDM wrapper. ASIO is the best driver to use and it will sometimes work to improve latency for people who don't have an audio interface and are using their on board sound card. So if there is a place in Audacity to select your driver, that's where you would find ASIO for all.

Hope this makes sense. My "technical" terms may not be the most accurate, but I try.

Annette

Share this post


Link to post
Share on other sites

I'm not very familiar with Audacity, but somewhere in the preferences/options you can change what sound card driver you record with, this is where you will be able to select the ASIO4ALL driver.

I've actually been working with ASIO4ALL recently (I'm working on doing some recordings to show the kind of quality you can get from free guitar and effects plugins using my old Behringer mixer and the on board sound) and I've been getting horrible latency with ASIO4ALL.

As Nutty mentioned, ASIO4ALL isn't truly ASIO so you won't get the same kind of performance. In my case I am still getting very high latencies, but at least I can hear the effects while I'm playing, even if it is significantly delayed.

-tkr

Share this post


Link to post
Share on other sites

I can't find anywhere to select the driver. I have attached a pic of one of the preference pages. I would think that it would be here if there was a selection to be made............dunno?

hb

8588.attach

Share this post


Link to post
Share on other sites

Hi HB,

During the asio4all installation, did you make sure there was a check mark in the box next to "off-line settings', it's on the 'select components to be installed' page? If not re-install... and then you'll be able to find it under... programs > asio4all > asio4all off-line settings...you can right click on it there{in the listing} and make a shortcut to your desktop if desired. Once you've opened asio4all from your desktop or the programs listing, make sure the proper device is selected. The slider on that window is for the buffer sample settings. I don't know much about that other than the lower the setting ie:128 or 64 etc will give better results, the final setting I imagine is determined by your machines capabilities. If interested I'm sure there's other's here who are more knowledgable on that aspect...hope this helped a little.

here's what it looks like on the desktop opened...

[ATTACH]8589[/ATTACH]

Share this post


Link to post
Share on other sites

Hi hb,

I just checked with a friend who is really good with this stuff and here is his reply:

I do not think that it does support ASIO drivers at all, I think it automatically chooses MME and I don't know of a way to change it to any other drivers.

I was pretty sure it wouldn't work. Have you tried increasing the latency (Audio to buffer:)? Not sure how much that will help.

Have you tried Reaper? It is more complex, but is free to try out. I start out with Music Creator 4. It's a great program and does a lot for the price $40. There is a Music Creator 5 out as well no for $40. Either one would be great. Music Creator 5 has a different gui which is geared for new users and has a wonderful sound centre which is worth the money alone.

Good luck.

Annette

Share this post


Link to post
Share on other sites

as an fyi edit to my previous post...this is a shot of it on my machine, unless you have or are using an alesis firewire interface, it will not have the same devises listed, just those on 'your' machine.

and if I recall correctly from back when I used audacity...it does indeed work with it.

Share this post


Link to post
Share on other sites

Thanks to all!

x4stringdrive: I will re-install.....the only thing I have right now is a desktop icon that takes me to the user manual....no icon in the tray or anything to take me to what you're mentioning.

Nutty: I will play around with the latency adjustment. I see the default setting when recording is a minus 130 milliseconds. Perhaps changing this can get the adjustment I'm looking for.

Thanks again...

hb

Share this post


Link to post
Share on other sites

x4stringdrive: I finally got the same screen that you have by checking that "off line" box. I wonder if there's a way to know that Audacity is using this new driver or it's just sitting in some back corner of your computer??????

Share this post


Link to post
Share on other sites

Not really sure HB, guess recording something now to compare against those before? I was under the impression once it's installed and the device selected its a given thats the driver used :dunno:

Share this post


Link to post
Share on other sites
x4stringdrive: I finally got the same screen that you have by checking that "off line" box. I wonder if there's a way to know that Audacity is using this new driver or it's just sitting in some back corner of your computer??????

In the audio preferences recording and playback boxes click the arrows next to the device names and select asio4all from the list (if

audacity recognises it).

Wile you're there- tick the playthrough boxes.

HTH

Mick

Share this post


Link to post
Share on other sites
In the audio preferences recording and playback boxes click the arrows next to the device names and select asio4all from the list (if

audacity recognises it).

Wile you're there- tick the playthrough boxes.

HTH

Mick

I'm using the newest version which is version1.3.9 and it doesn't have that. I can go to "devices" but the only two choices I have are " Realtec HD Audio output" or "Microsoft Soundmapper". That makes me wonder if Audacity is even going to use that driver or not??????

Also, there is no "playthrough" box that I can find. ?????

Then I went to the Realtec Audio thingy (which is what looks like what I am using, and it says that it's driver is a "Direct X Version" and I don't see any way to change that.

hb

hb

Share this post


Link to post
Share on other sites

I don't think it does hb. That's what my friend confirmed as well and he's the real teckie guy.

Wish there was a better answer.

Annette

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×