Jump to content
Tekker

Computer Gurus Needed - Sound Card Problem

Recommended Posts

Tekker    1

I've been trying to solve this issue on a couple recording forums, and unfortunately, the consensus was basically to just get a new card. But I know there are a few computer gurus here, so before throwing in the towel and replacing it I'd like to get their opinions on this issue.

My Aardvark Q10 does not work with my new-ish computer running SP2 or SP3. It does work with SP1, but I don't want to use that online since it is not up to date. Aardvark is out of business and the only driver they released was for SP1. However, the Q10 worked just fine on my old computer with SP2 and some users on the Aardvark yahoo group said it worked fine with SP2 and SP3, so I'm not sure why it won't work on my computer.

The problem I'm having is popping/stuttering during playback on full projects (multiple tracks and effects). These same projects played perfectly when I tried it with SP1, no problems at all and there was even a fairly low CPU and disk usage.

I was having problem with popping while zooming or scrolling while playback was going even with just one track playing and I also did some test recording and got popping in that as well. Both these problems were fixed by lowering the graphics accelerator down one notch. So there is something funky going on with my system. But even reducing it down all the way does not fix the problem in a full project.

Computer specs:

Processor: Amd Athlon

X2 5200+ Dual-Core

Mobo: ASUS M2V-MX SE Socket AM2 VIA K8M890

Memory: 2GB Corsair RAM

Power Supply: 550watt Power Supply

OS: Windows XP SP2

Sound card: Aardvark Q10 - driver 7.13

Recording Software: Samplitude v10.1

Things I've tried thus far:

* Increased the buffers on the Q10 and in Samplitude.

* Tested different drivers (ASIO, MME, and WDM)

* Moved the Q10 to another PCI slot (this computer only has two PCI slots).

* Played with the Trackspeed settings in Samplitude and even disabled it altogether.

* Disabled the on board sound, network adapter, com port, and printer port.

* Disabled system sounds.

* Checked the logfiles to see if there were warnings or errors after booting up. There weren't any.

* Ran DPC Latencycheck while zooming with playback going in Samplitude and the max was 50us. It said my machine should be able to handle real-time streaming without dropouts.

* Tested it with another Windows XP installation (tried both SP2 and SP3) on another partition which has nothing on it but Samplitude and my Aardvark Q10 driver.

* Tested it with XP SP1 on the other partition and it worked. (So far this has been the only thing to get good results in a full project.)

* Tested with another hard drive for the operating system drive.

* Someone on another forum mentioned disabling AMD's Cool 'n Quiet feature (said it was worse than Intel's Speedstep, which has been known to cause the issues I'm having).... Which sounded promising, but it was already disabled in the BIOS.

* I've also tried playing my guitar through the Q10 using VST monitoring in Samplitude to hear my VST effects in real time and it works flawlessly. So it can handle realtime intput/output, it just can't playback full projects.

* I tested the same projects with the onboard sound instead of the Q10 and the onboard sound works perfectly.

I think that's everything that has been tried so far. If anyone has any other ideas on things to try to help solve this issue, I would really appreciate it!!

Thanks,

-tkr

Share this post


Link to post
Share on other sites

Hi Tkr, this won't help figure out why, but can you export the Aardvarks driver out of sp1 and load it into your new set-up or at least double check that sp2 or 3 has recognized it in your driver file....and as if that didn't tell you enough, you now know I'm no guru....best of luck with it!

Share this post


Link to post
Share on other sites
carol m    64

Clearly I wouldn't have a clue, but I wish you well in your search for a solution. If anyone can solve it, I'm sure you are the guy to do it - with maybe a little help from your techy friends. :winkthumb:

Share this post


Link to post
Share on other sites
Tekker    1
Hi Tkr, this won't help figure out why, but can you export the Aardvarks driver out of sp1 and load it into your new set-up or at least double check that sp2 or 3 has recognized it in your driver file....and as if that didn't tell you enough, you now know I'm no guru....best of luck with it!

The driver does load in SP2 and SP3 because sound does come out of the sound card, it just pops and stutters a LOT. :(

Clearly I wouldn't have a clue, but I wish you well in your search for a solution. If anyone can solve it, I'm sure you are the guy to do it - with maybe a little help from your techy friends. :winkthumb:

Thanks Carol. The kinds of problems where something is wrong with the computer itself are out of my knowledge base as I'm not much of a computer tech. I know know enough be able to do what I'm told to do most of the time without breaking something.... :D But I'm not very good at troubleshooting these type of problems.

-tkr

Share this post


Link to post
Share on other sites
knight46    2

Tekker,

These kinds of problems are sometimes the most difficult to pin down, but that is not to say they can't be found.

If I read correctly, the Q10 worked on an older computer with SP2 and others say it works with SP2 and SP3. But now it will not work with your new puter using SP2.

If I were having this problem I would list the spec's and settings for the old puter with SP2 where Q10 worked and this puter where it doesn't work and see if I could find an abnormality.

You might want to set the old puter to Default spec's and see if that works and then set the new one to Default...kind of a start both from ground "0".

Hope this helps a little...

Share this post


Link to post
Share on other sites
Tekker    1
If I read correctly, the Q10 worked on an older computer with SP2 and others say it works with SP2 and SP3. But now it will not work with your new puter using SP2.

Correct, it also doesn't work with SP3 on my new computer, which I tested on my other partition.

If I were having this problem I would list the spec's and settings for the old puter with SP2 where Q10 worked and this puter where it doesn't work and see if I could find an abnormality.

Here are the old computer specs:

Processor: AMD Athlon XP2800+ Barton

Motherboard: Asus A7N8XE Deluxe Socket A Motherboard

Memory: (2) Corsair VS1GB300C3 ValueSelect 1GB DDR SDRAM

Video Card: Rage Fury Pro/Xpert 2000 Pro

Sound Card: Aardvark Q10 and Mobo's Onboard Sound

Power Supply: Herolchi Electronic Co. HEC-300AR-T 300W

OS: XP Pro SP2

And by "settings", you're referring to BIOS settings, correct? If so, it may be hard to compare the two because they both have very different BIOS layouts. I can give it a try though and see if anything obvious stands out. Do you want me to list everything?

-tkr

Share this post


Link to post
Share on other sites
fly135    5

Just a thought... Check your System Properties, Advanced, Performance, Settings, Advanced. There is a setting to optimize scheduling. Try switching it to "Background Services" or vice versa and see if it has any affect.

Also check the Windows Task Manager and make sure that you have 150,000 Kbytes of memory or more available under Performance, Physical Memory, so that you are paging memory too frequently.

Share this post


Link to post
Share on other sites
knight46    2

Those are some excellent suggestions Fly. Tekker those are the types of settings that I was refering to above. Usually the BIOS doesn't have a great effect on this type of problem.

Also what is the video card in your new computer?

Share this post


Link to post
Share on other sites
Tekker    1
Just a thought... Check your System Properties, Advanced, Performance, Settings, Advanced. There is a setting to optimize scheduling. Try switching it to "Background Services" or vice versa and see if it has any affect.

Just tried it and I still got the same result.

I also tried changing the second option to adjust for best performance of system cache, just to see if it made any difference and it didn't.

Also check the Windows Task Manager and make sure that you have 150,000 Kbytes of memory or more available under Performance, Physical Memory, so that you are paging memory too frequently.

While Samplitude is playing (and stuttering) I still have over 860,000 kB available. After stopping playback it goes up to over 1,130,000 kB.

-tkr

Share this post


Link to post
Share on other sites
knight46    2

Tekker,

Take a look at your Task List while Samplitude is playing to see if there is some other program or application interfering. It sounds like you have sufficient memory available, Samplitude is using about 25% when playing, but something is using CPU and interfering. Seems that everything I can find relates to Sample Rate, so if you have played with the Sample Rate, something else may be stealing your CPU usage.

Share this post


Link to post
Share on other sites
Tekker    1
Tekker,

Take a look at your Task List while Samplitude is playing to see if there is some other program or application interfering.

When I press play, it takes a long time before it starts playing and during this time Samp takes up about about 90%+ of the CPU. Once it starts playing it drops down to about 70%-80%. It is a larger project with several effects, but it should play just fine. It does play when I use the onboard sound instead of the Q10 and it played when I tested it on SP1 with the Q10.

No other programs are taking any CPU while Samplitude is running.

I have also tested it on another installation of XP (I tried both SP2 and SP3) which had nothing but my motherboard drivers, Samplitude, and my Q10 driver. No other programs were installed (no antivirus, or anything) and it still did the same thing.

Seems that everything I can find relates to Sample Rate, so if you have played with the Sample Rate, something else may be stealing your CPU usage.

All of my projects are at 44.1kHz. I haven't done any sample rate changes.

-tkr

Share this post


Link to post
Share on other sites
knight46    2

Darn Tekker, this is a son-of-a-gun. Let me talk to a friend of mine tonight (Super Geek) and see if he has any suggestions. Sorry I couldn't be of more help.

One other thing you might check:

Under Sounds and Audio/Audio/Sounds Playback/Advanced Audio Properties/Performance/Audio Playback Settings

Check out the two sliders...maybe???

Share this post


Link to post
Share on other sites
Tekker    1
Darn Tekker, this is a son-of-a-gun. Let me talk to a friend of mine tonight (Super Geek) and see if he has any suggestions.

Thanks, that would be great. I like super geeks! :D

One other thing you might check:

Under Sounds and Audio/Audio/Sounds Playback/Advanced Audio Properties/Performance/Audio Playback Settings

Check out the two sliders...maybe???

The Q10 doesn't have any advanced options. The button is grayed out.

-tkr

Share this post


Link to post
Share on other sites
OldG    3

Have you used the latest Motherboard and Graphics drivers? worth checking the HD(s) set to DMA - basically make sure every component is seated well set to work and using the latest drivers...

If you are still stuggling,how about a clean install of an audio optimized stripped down XP? (with sp3 integrated)

You can D/L it here at the Reaper forum... just use your XP serial to install

I run it on an old Athlon XP200 and it flies!( only using 170 mb memory to run) well worth a try, I reckon..

Share this post


Link to post
Share on other sites
OldG    3

Oh, check the IRQ of the Aardvark - if it's sharing recourses with the Vid card (I'm betting they are both on 13 with a bunch of others), this could be your problem.

Googe should get you a solution fairly easiy ( I'm short on time now, or I would for ya :) )

Share this post


Link to post
Share on other sites
Tekker    1
Oh, check the IRQ of the Aardvark - if it's sharing recourses with the Vid card (I'm betting they are both on 13 with a bunch of others), this could be your problem.

Here is my IRQ List:

(ISA) 0 High precision event timer

(ISA) 4 Communications Port (COM1)

(ISA) 6 Standard floppy disk controller

(ISA) 8 High precision event timer

(ISA) 9 Microsoft ACPI-Compliant System

(ISA) 13 Numeric data processor

(ISA) 14 Primary IDE Channel

(ISA) 15 Secondary IDE Channel

(PCI) 16 VIA Chrome9 HC IGP

(PCI) 17 Aark 24, Ark 20/20 or Direct Pro Q10 (my soundcard driver)

(PCI) 17 Microsoft UAA Bus Driver for High Definition Audio

(PCI) 20 Via Rev 5 or later USB Universal Host Controller

(PCI) 21 Standard Dual channel PCI IDE Controller

(PCI) 21 VIA Rev 5 or later USB Universal Host Controller

(PCI) 21 VIA USB Enhanced Host Controller

(PCI) 22 VIA Rev 5 or later USB Universal Host Controller

(PCI) 23 VIA Rev 5 or later USB Universal Host Controller

(PCI) 23 VIA Rhine II Fast Ethernet Adapter

(PCI) 27 VIA PCI to PCI Bridge Controller

(PCI) 31 VIA PCI to PCI Bridge Controller

It doesn't appear to be conflicting with a bunch of stuff. I have also tried moving the Q10 to another PCI slot (this was one of the first things I tried) but it still does the same thing.

I've got all the drivers downloaded (BIOS, chipset, audio, video, etc...), so I'll try installing them one at a time and see if anything changes.... Keeping fingers crossed! :)

-tkr

Share this post


Link to post
Share on other sites
Tekker    1

I installed the video, audio, LAN, and chipset drivers and there were no changes. I haven't done the BIOS yet (need another program for that apparently)... Should I even bother with updating the BIOS?

I also upgraded the firmware for Samplitude's dongle (on the off chance it had something to do with that) and again, no change. :(

-tkr

Share this post


Link to post
Share on other sites
fly135    5

I'll throw another one out there....

Check your System Properties, Hardware, Device Manager, IDE Controller, Primary IDE, Advanced Settings and see if the current transfer mode for the drive is set to "Ultra DMA Mode XX? Where XX is a number.

Share this post


Link to post
Share on other sites
Tekker    1
Check your System Properties, Hardware, Device Manager, IDE Controller, Primary IDE, Advanced Settings and see if the current transfer mode for the drive is set to "Ultra DMA Mode XX? Where XX is a number.

Yes it is. It's Ultra DMA Mode 5. Is this a good thing or a bad thing?

-tkr

Share this post


Link to post
Share on other sites
Tekker    1
Good thing.

Darn, I was hoping for a bad thing. There must be something (anything) wrong with my system so that it can be fixed.

-tkr

Share this post


Link to post
Share on other sites
Tekker    1

I've actually already done all of those tweaks mentioned in the document (and more) on my other installation of XP which I got from several XP tweak sites (such as musicxp.net and tweakxp.com).

-tkr

Share this post


Link to post
Share on other sites
Tekker    1
This thread over at the Reaper forum might help shed some light...

I tried running DPC Latency Checker before, but I just tried it again and the max was a little higher this time, but not by much.

I've attached a screen shot. With this particular project the audio only plays on a few tracks (some tracks don't play at all) and then all of the audio completely cuts out after about 30-ish seconds so there is just silence even though it is still playing.

-tkr

7250.attach

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×