Jump to content
Father Goose

Reaper: Imported MIDI - playback no sound

Recommended Posts

I’ve imported a MIDI-01 drum track into Reaper but I can get any sound during playback.

In FX, I’ve already tried various MIDI & other plug-ins that are available.

The only plug-in that gives out any sound is VSTi ReaSynth. But it sounds like “things that go ‘thud’ in the night”.

Imported full MIDI songs too but still no sound.

Any know-how anyone

….. please?

Share this post


Link to post
Share on other sites

Is your VST folder listed in reaper? If they are in a different folder to Reasynth etc, then you have to go to Options / Preferences / VST and then add the directory with the button at the top right.

Ian

Share this post


Link to post
Share on other sites

Hi Ian

Yes. The VST folder is listed if I recalled correctly. During the setup/installation, I've clicked ADD a few times too just to be sure.

Unfortunately, I dont have access to my PC right now so I cant verify that.

Besides that, anything else I should be on the look-out for?

Tks/Goose.

Share this post


Link to post
Share on other sites
Might want to check your drivers for updates...

and I found this about no midi sound at their site...

M-AUDIO - Knowledge Base

Tks X4.

No problem playing MIDI files using MS Windows Media Player, Anvil and such. Its only on Reaper that I'm not able too.

BTW, I've 'trawled' the Reaper Forums for solutions and have tried various fix-its; but to no avail.

EDIT : In Reaper Trouble-shooting guide, the following doesn’t work either.

"When I try to play an imported MIDI track, it is silent

This can be a routing, sound card or setup issue – see previous page.

In addition it may be caused by a MIDI specific issue. This occurs when the track has not been assigned to a valid MIDI Output device or software synthesizer.

If you are using a MIDI Hardware device, display the track’s Routing Window and make sure it is assigned to a MIDI Hardware Device.

If you are not using a MIDI Hardware device, display the FX Window for the track, and insert a software synthesizer of your choice (usually DXi or VSTi)."

Share this post


Link to post
Share on other sites

Well I won't be much help as I don't use reaper...but I like a challenge now an then.

found this in reapers manual, this is based on showing all of the individual tracks from the midi, but works the same if you only open it on one track{all combined}

if you notice in this shot, they're not selecting the 1010 to choose settings for output.

Don't know if this will work or if you've tried, hope it helps!

[ATTACH]6840[/ATTACH]

Share this post


Link to post
Share on other sites

Once I got home, I uninstall and re-installed Reaper.

Set the options & preferences again, and guess what?

It worked! Now I can hear all the imported MIDI tracks.

But it was a letdown, cos you cant add FX (delay, stereo etc) to the MIDI tracks. Cant even adjust the playback volume.

(or can you???)

Looks like i gotta start from scratch. Program drum tracks on LeafDrums, bass using the gtr & etc.

No short cuts here!

Tks all for the help!

Share this post


Link to post
Share on other sites
OldG    3

You should be able to treat midi tracks like audio...You'll need a VSTi inserted for the fx to work on. Tracks have sliders for volume pan adjustments.

Try opening a new project > drop a midi file on to the blank track pane to the left > click fx button > add VSTi or DXi instrument (to voice the midi data) > add fx to taste from choice of vst/DX/JS effects > adjust volume/pan sliders to taste

Share this post


Link to post
Share on other sites
You should be able to treat midi tracks like audio...You'll need a VSTi inserted for the fx to work on. Tracks have sliders for volume pan adjustments.

Try opening a new project > drop a midi file on to the blank track pane to the left > click fx button > add VSTi or DXi instrument (to voice the midi data) > add fx to taste from choice of vst/DX/JS effects > adjust volume/pan sliders to taste

Hmmm.....the VSTi or DXi should come BEFORE the other FXs?

Tks. I'll give it a try.

Share this post


Link to post
Share on other sites

Nope.

FYI, the sliders CAN slide left/right or up/down but there is no difference in the output sound.:brickwall:

I must be doing it wrong :unsure:

... or "technically challenged" so to speak. Hehehe

Share this post


Link to post
Share on other sites
OldG    3

Ok...which VSTi are you using? For drums, SuperDrumFX should do the job as described in my previous post - (tested on my family PC with Reaper 2.108 installed no adjustments to preferences)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×