Jump to content
justinthyme

Audacity recording problem

Recommended Posts

justinthyme    3

I'm trying to record some improv over a BT, imported as an .mp3.

When I hit the record button the .mp3 is 'leaked' onto the new track at a low volume - the guitar then gets mixed in with this so I don't get a clean track with just the guitar on it.

The "play other tracks while recording new one" box is checked, but not the "software playthrough" one (tho this makes no difference to the problem if it is checked).

I'm using a Behringer Xenyx 1222 FX mixer (USB) - so "MME:USB audio CODEC" is chosen for both the playback and recording device.

Any idea what's causing this?

Advice appreciated - thanks. :helpsmili

Share this post


Link to post
Share on other sites

Not sure about your mixer, but on mine I have two volume level controls for each channel, one for main one for monitor. I have to turn down completely the monitor level to avoid bleed-thru. I don't use audacity much any more so am no help there. Might check{if using windows} if unchecking "use default devises only" in "sound and audio devises" under "audio" tab makes a difference...just a thought.

Edit...up-date...I just opened audacity, and I was backwards in my advise on level settings.. on mine I turn up monitor levels to hear whats already recorded and turn down the main level on my play back channel on the mixer...sorry about that...hope it helps. I run my pc audio into and out of my monitor and I also use an external sound card, so take my reply with caution as I'm sure you know.

Share this post


Link to post
Share on other sites
justinthyme    3

Thanks for the response, X4String.

There are 2 sliders on the Behringer - Main Mix and CD/Tape Ret. If I turn down the latter it stops the bleed, but I get no sound at all - not even through headphones. Doing it the other way cuts out the sound to my speakers, but allows the bleed to continue in Audacity.

Fiddling with the mike and speaker sliders in Audacity doesn't help either. :brickwall:

The "use default devices only" is unchecked.

If you think of anything else ...

Thanks again.

Share this post


Link to post
Share on other sites

Lol...I just re-read my reply.."monitor" haha I run my audio thru my "mixer" is what I meant to say.

Justinthyme, maybe try bypassing your mixer if you can and that will at least pinpoint which is causing trouble. from there we can proceed to figure it out, maybe.

Share this post


Link to post
Share on other sites
tomg123    0

Probably not much help, but the only time this happened to me is when the sound from my headphones go into the mic (if your using a mic).....one other hunch, and i don't know why i say this because it may not be related, but just to make sure that drop down box (line-in, stero mix, mono mix) is selected right.

Share this post


Link to post
Share on other sites

Just had a thought Justin,{Yeah I get those once in a while} Does your mixer have fader controls? maybe pushing one track to one side and record on the other might be a temporary fix.

Share this post


Link to post
Share on other sites
Tekker    1

Have you made sure that your soundcard is set to "line in" (or "mic" input depending on which one your using) in your soundcard's mixer?

Depending on which soundcard you have, there will be an option in the mixer called "Stereo mixer", or "Record what you hear", or something like one of these. This will record everything going through your soundcard (including the mp3). So make sure you have the the proper input selected and not one of these options.

If you're not sure how to check this, see HERE.

-tkr

Share this post


Link to post
Share on other sites
justinthyme    3

Tekker, when I go into the soundcard (Realtek Audio) mixer with USB Audio Codec as the device, the 'recording' option is greyed out and there is just a blank box below it where the various tickboxes should be. I should mention that the guitar is plugged into the Behringer mixing device, not the putr. Thinking about it, that may be why - sorry, but I'm so far down the learning curve with this that I'm not even at the stage where I know what's important to mention! :oops:

X4String - I panned the guitar all the way left on the mixer, panned the BT all the way right in Audacity and that works!! So - thank you for providing that quick fix :claping:

Now there's just one more issue with that arrangement - I have to turn the input on the guitar way up to get it to 'balance' with the BT in Audacity. That makes things enormously loud inside my little 'studio' - so I guess its going to have to be a headphone job.

Oh, and one other thing which I find very odd - when I slide the 'microphone' slider all the way to the right in Audacity - it causes the sound to mute completely ('mute all' gets checked in the soundcard mixer). Is this normal? Seems counterproductive?

Once again, thank you both for the help :salute:

Share this post


Link to post
Share on other sites

Hey Justin, Tekker is the one for "real" help, please be patient,as I'm sure he'll probably get to the bottom of the problem faster than most.

In the meantime... you can load your backing track in audacity, go to "edit" then "select" then "all", this will highlite the entire wav file. then go to "effects" then "amplify" from here you can slide the control to your left to lower the decibles of your bt to a tolerable level {use preveiw until your satisfied, then click OK}....hope this helps till you get er figured out.......Kenny

Share this post


Link to post
Share on other sites
fly135    5

Justin, do you have the output of the computer fed into the mixer? If so then just pull the audio feed from the computer off the mixer and see if that has an effect.

Share this post


Link to post
Share on other sites
Tekker    1
X4String - I panned the guitar all the way left on the mixer, panned the BT all the way right in Audacity and that works!!

OK, I missed the part before about you monitoring through your mixer. I thought you were monitoring directly from your computer.

Would you be able to monitor off of your computer instead of the mixer? Or do you want to be able to use the mixer with your computer turned off without having to change the speaker connections from the computer to the mixer?

Tekker, when I go into the soundcard (Realtek Audio) mixer with USB Audio Codec as the device, the 'recording' option is greyed out and there is just a blank box below it where the various tickboxes should be.

Are you using your mixer's USB port to go into the computer or are you using an output on the mixer to go into your computer's soundcard?

If you're using your soundcard, then see if you have other devices in the Sounds and Audio Devices Properties. The USB Audio Codec sounds like it's probably your USB mixer. It makes sense that it wouldn't have options for recording since you'd make any volume changes directly on the mixer itself.

This will allow you to change your recording volume and get a better mix with the mp3.

Oh, and one other thing which I find very odd - when I slide the 'microphone' slider all the way to the right in Audacity - it causes the sound to mute completely ('mute all' gets checked in the soundcard mixer). Is this normal? Seems counterproductive?

Looks like a bug in Audacity as that's definitely not normal.

-tkr

Share this post


Link to post
Share on other sites
justinthyme    3

Guys, the mixer has a slightly strange setup for porting to and from the computer (if porting is the right term). The only way to use USB is to attach RCA plugs to INPUT and OUTPUT ports marked CD/TAPE on the mixer and run the leads through a converter (supplied with the mixer for this purpose) and then into a USB port in the computer. There is a single slider controlling marked CD/TAPE RET, and dual sliders marked MAIN MIX on the mixer.

Tekker, I can't monitor from the soundcard because I'm using studio monitors with large 3 pronged plugs (sorry, no idea what they are called) which plug into the mixer.

Does any of that make any difference?

Cheers.

Share this post


Link to post
Share on other sites
Tekker    1
Tekker, I can't monitor from the soundcard because I'm using studio monitors with large 3 pronged plugs (sorry, no idea what they are called) which plug into the mixer.

Those are called XLR connectors (the same connectors that microphones use). This is the better way over connecting to your computer because your mixer and monitors are using balanced connectors. This gives less noise/interference and hotter signal.

However, it poses a problem for routing since from what I can tell the tape outputs are connected to the main outputs with no way to send mixer channels to each one separately.

I take it you are you using the mixer via USB (instead of using the soundcard)?

-tkr

Share this post


Link to post
Share on other sites
justinthyme    3

I take it you are you using the mixer via USB (instead of using the soundcard)?

-tkr

Yes. I think so.

Would I be better off outputting from the mixer to the putr soundcard via an RCA-phono plug adapter? LOL - I'm completely lost!

Share this post


Link to post
Share on other sites
Hilch    0

Out of curiousity do you have a webb cam ?

Something very simular happened to me ..

And that pesky webb cam was the fault , it was picking up and recording , I was stumped as to how all my swearing was ending up on my tracks ..

Just a thought

Trev

Share this post


Link to post
Share on other sites

Justin, heres a simple look at a basic hook-up using your PC soundcard, with out usb...I know this is really basic and you probably already know how, but I was bored and so......

This is pretty much how mines set-up, minus the mic, drum machine and keyboard etc.. Yes I use 2 pairs of speakers, but still the same with only one pair. No this doesn't answer your main questions, I'm leaving that to Tekker, so you won't have to undo anything I reccomend..lol

click on

[ATTACH]5462[/ATTACH]

ps.. on my mixer I have rec-out using rca plugs and changes to 1/8 inch at other end{from radio shack} which goes from mixer to pc. and I use a 1/8 inch{one end} to 1/4 inch adapter{other end} from pc out to mixer "line in"

Share this post


Link to post
Share on other sites
Tekker    1
Hey Tekker heres a link to the manual for this in pdf if your interested. I'm also wondering, since its part of the subject...[/url]

Yeah, I was looking at that one before. I couldn't find a big enough picture of the mixer to be able to read all the connections, so I had to download the manual and use their picture. lol But even in the text there doesn't appear to be a way to send channels separately to the tape and main outputs.

whats the advantage of usb connection over line in/out?

In this case the only advantage would be bypassing the stock soundcard. ;)

Firewire is really the way to go (if given a choice) as it is faster and can handle long file transfers (like recording audio) much better than USB.

Yes. I think so.

Just to make sure, are you using the RCA-USB adapter thingie to go into your USB port?

Would I be better off outputting from the mixer to the putr soundcard via an RCA-phono plug adapter? LOL - I'm completely lost!

As mentioned above, it probably would be best to bypass the stock soundcard.... But you can definitely try recording both ways and see which one sounds better. To get the best comparison, plug a CD-player into it so you can be sure the exact same performance is recorded both times. I noticed before that using the digital S/PDIF output on my Digitech pedal sounded much worse than using the main R/L outputs, so you won't know for sure until you try it out. :)

Justin, heres a simple look at a basic hook-up using your PC soundcard, with out usb...

What mixer do you have and how are you getting sound out and back into your mixer when connected to your computer?

I think the mixer just isn't setup to do this properly. Sending tracks to the computer is no problem.... But getting them back into the mixer without combining with the original tracks means you have to have a way to keep the original signal from going to the main mix, which can't be done on this mixer using the USB outputs.

The only way to get it to work is to pan the guitar and backing track opposite each other so they don't over lap as Xstring suggested earlier. It doesn't look like there's going to be a way around it.

There's only one other option I can think of (aside from panning) but you'd have to use the main outputs (not the USB) and it'd bypass all your mixer effects, EQ, panning, volume fader, so pretty much the only thing you'd be able to do to your guitar track is adjust the gain.... Probably not what you want as it'd defeat the purpose of getting the mixer in the first place. LOL

-tkr

Share this post


Link to post
Share on other sites

Thanks Tekker for all the info....:thumbup1:

I hope I wasn't confusing the situation to much. I use a Yamaha EMX 660 powered mixer. On my set up I take the audio out from the PC{via external sound card} send it thru "line " in jack on the mixer{one of six channels} and I use the "rec-out" rca output to send the signal back thru the sound card to the PC.

I hope I was correct in assuming it would be the same without an external card. I also send my drum machine and keyboard thru seperate channels, have a "instrument channel" which I send my guitar thru via my fx processor{also send my mic thru this first as well}. just didn't include all of this in the photo so as not to be to confusing. Maybe I have mine set-up in a not so "best way to...?" and I would welcome any comments you can offer....thanks T

Share this post


Link to post
Share on other sites
justinthyme    3

Tekker - to answer your question above, yes - the adapter is between the RCA plugs coming out of the mixer and the USB port on the computer.

It seems from what you've said that there is no way to do this without the panning workaround, which is disappointing given the 'sophisticated' appearance of the machine. But that's OK - at least it works!

Guys, at the risk of repeating myself I have to say that I really appreciate the time and effort you put not just into answering my post here - but the invaluable contributions you make elsewhere in this forum. You are the best!! :claping: :claping:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×