Jump to content
Chaotic Kittie

Latency in audacity?

Recommended Posts

I notice that if I first record a rhythm track, then record a lead track over this one, when played, the lead track falls behind by slightly less than a second from the rhythm track, making it sound horribly out of time. I tried correcting this by removing small bits of the empty bits on the lead track, so it would synchronize, but this didn't help, I can only make it very, very slightly behind the rhythm track or very, very slightly before it...

Any help?

Share this post


Link to post
Share on other sites

Downloaded the driver.. a question, do I have to configure them to anything specific to fix the thing with the latency? If so how, because the manual hardly makes any sense to me at all.

Share this post


Link to post
Share on other sites

CK, My advise is try a quick dual track recording and see how it goes. The default settings may be all that you need. asio4all is a off-line app. and so doesn't effect your other settings, use only those in asio4all for tinkering if need be.

If it helps, heres my settings...click on the desktop icon and look at "devise list" be sure your sound card/source is showing the "running" symbol {match with shown in "legend"}

under Advanced...

Latency compensation =16 samples for both in and out

use hardware buffer=tick the box

buffer offset=1Ms

ac97 troubleshooting= ? I use a soundblaster card not ac97

ASIO buffer size=120 samples

Heres a pic of the settings screen and some background info.

ASIO4ALL - Universal ASIO Driver For WDM Audio

Share this post


Link to post
Share on other sites

ASIO buffer size=120 samples

I found the best latency compensation came from reducing the buffer size as much as possible... I'm running 64 samples, which gets me down to 4ms using Acid ( my recording program) and 2ms for Amplitube ( a virtual amp VST). Try 64 samples X4, I bet you'll be able to feel/hear the difference.:winkthumb:

Here is a screenie of my panel,btw....

Share this post


Link to post
Share on other sites
I found the best latency compensation came from reducing the buffer size as much as possible... I'm running 64 samples, which gets me down to 4ms using Acid ( my recording program) and 2ms for Amplitube ( a virtual amp VST). Try 64 samples X4, I bet you'll be able to feel/hear the difference.:winkthumb:

Here is a screenie of my panel,btw....

Thanks so much OldG, My settings have been that way since the day I got it up and running, never messed around with it after that first day, figured if it wasn't broken why try and fix it. But now with your tips I'm gonna have to experiment some more...Thanks for sharing:winkthumb:

Share this post


Link to post
Share on other sites

That's odd, CK - for me, Audacity is by FAR the lowest latency recording program. What are the specs on your computer / sound card, and how are you plugging your guitar into the computer?

Share this post


Link to post
Share on other sites

I use a Line 6 POD 2.0 to connect to the computer, through the AUX-in or whatever it's called.

Managed to solve the problem somewhat, I now can erase enough of the track to make the tracks fall in sync. But I'd prefer not to have to.

My computer is a P4 3,2 Ghz, 1024mb ram, my soundcard is a Creative SoundBlaster Audigy 2.

Share this post


Link to post
Share on other sites

CK.. not sure on whats going on there, but maybe something in your settings...Check this out & see if it helps..if you've already tried these steps I'm not sure what else to offer.

in Audacity go to "edit" select "preferences" then select "Audio I/O"

and be sure "play other tracks while recording new one" has a check{tick} mark in the box next to it. This is all I have checked, but you may also want to try ticking the "software playthrough" box.

Something else that may allow a clue to this problem is... May be your system lags in processing power to handle too much at the same time... make sure your not running unnessesary programs in the background, when I record I disable everything I can{anti-virus, network connections, auto up-dates..Etc. Etc.}.

Surely theres a "guru" out here somewhere that can offer more.

Share this post


Link to post
Share on other sites

I am using Audacity with a Line 6 toneport UX-1....I only have 512mb of ram and get no latency.

I know you have a great sound card but...Maybe thats where the latency is occuring.

Share this post


Link to post
Share on other sites

There's definitely something going on there. My computer is pretty much the same specs, except I'm using the stock "onboard" soundcard - I record with my antivirus, e-mail scanner, firewall, network connections and everything still loaded, and still have no latency problems. I had never even tweaked the ASIO settings, have always just run with the defaults. Unless you've got some programs loaded that are real RAM hogs, the only thing I can figure is that it's something with the soundcard.

Share this post


Link to post
Share on other sites

CK can you answer a couple of questions?

Load Audacity.

Press Ctrl Alt Del to bring up Task Manager.

The first tab "applications".

Is there anything other than Audacity running?

Third tab "performance".

What's your CPU usage percentage? (mine is about 50%)

What is the PF usage?

How much physical memory is available?

Close task manager.

Go to Control Panel.....System, Advanced tab, Performance Settings, Advanced tab.

What amount of Virtual Memory do you have?

What anti virus do you have?

Share this post


Link to post
Share on other sites

I have heard that the newest Beta Version of Audacity has fixed some of the out of synch problems folks have had in the past. It's still free and it seems to work fine for me even tough it's still listed as unstable. Worth a shot as you can still access the old version if it doesn't work...

BSR

Share this post


Link to post
Share on other sites
I have heard that the newest Beta Version of Audacity has fixed some of the out of synch problems folks have had in the past. It's still free and it seems to work fine for me even tough it's still listed as unstable. Worth a shot as you can still access the old version if it doesn't work...

BSR

Couple of notes.....

I've been using Audacity 1.3.0 (windows port) for a long while. My mixing board was directly connected to the PC. I had zero latency. I recently introduced new hardware into the chain and created a latency problem. The latency occurred especially when I used direct import of percussion loops. With the new hardware piece latency was terrible. The drum loops were directly imported and did not go through the hardware. When recording over the loops, the recording had to go through a longer chain, hence creating an apparent latency problem.

I upgraded to Audacity 1.3.3 because of their notes regarding latency. It did not help. I've tried all the tricks suggested to relieve latency. They have not worked.

Of course, the sound card is not an upper end card and that may be a large part of the problem in that is just can't process I/O that quickly. In the meantime, I have been trying out Kristal which has ASIO support and I have no latency with it. So far so good.

I much prefer Audacity with it's simple and more intuitive GUI. However, I don't particularly want to spend time adjusting tracks because of latency. That takes all the fun out of it.

**

LC

Share this post


Link to post
Share on other sites

Okay, sorry I forgot this thread... but the problem was solved, kind of, but instead it has now turned the OTHER way... Now when I record, there is no latency, but rather the opposite. Which means that when I play what I've recorded against the backing track, what I'm playing now starts 0,5 secs or so BEFORE the BT music starts!

I've made sure that I'm not playing out of time myself, by having others listen.

Latency at least makes sense, but this really doesn't... Any ideas?

Also, I know you can remove parts of a track to make it sync... is there any way to move it FORWARD rather than backwards?

Share this post


Link to post
Share on other sites

You should be able to "line up" the tracks by shifting (sliding) them forward or back....but it's a tedious process to get it exactly right!!!

Share this post


Link to post
Share on other sites

Darn, that doesn't work... It won't fall in sync, I can only get it either slightly before the B.T music starts, or slightly after... both sounds horrible, as you can probably imagine!

Any ideas? =(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×